Can't install purescript-path


#1

Hello,

I tried to play with Data.Path package but could not import it. So I tried to install the purecript-path package and ended up with these sort of questions after I chose something the whole project became unsubale and I even couldn’t start psci in the context of the project.

It looks like package repository is broken.

Any ideas?

Thank you.

c:\dev\projects\test>bower install purescript-path

bower purescript-path#* cached purescript-path.git#0.2.7
bower purescript-path#* validate 0.2.7 against purescript-path.git#*
bower purescript-strings#~0.4.0 cached purescript-strings.git#0.4.5
bower purescript-strings#~0.4.0 validate 0.4.5 against purescript-strings.git#~0.4.0
bower purescript-foldable-traversable#~0.1.3 cached purescript-foldable-traversable.git#0.1.6
bower purescript-foldable-traversable#~0.1.3 validate 0.1.6 purescript/purescript-foldable-traversable.git#~0.1.3
bower purescript-arrays#~0.2.1 cached purescript-arrays.git#0.2.1
bower purescript-arrays#~0.2.1 validate 0.2.1 against purescript-arrays.git#~0.2.1
bower purescript-maybe#~0.2.1 cached purescript-maybe.git#0.2.2
bower purescript-maybe#~0.2.1 validate 0.2.2 against purescript-maybe.git#~0.2.1
bower purescript-control#~0.2.0 cached purescript-control.git#0.2.6
bower purescript-control#~0.2.0 validate 0.2.6 against purescript-control.git#~0.2.0
bower purescript-arrays#~0.3.0 cached purescript-arrays.git#0.3.7
bower purescript-arrays#~0.3.0 validate 0.3.7 against purescript-arrays.git#~0.3.0
bower purescript-either#~0.1.4 cached purescript-either.git#0.1.8
bower purescript-either#~0.1.4 validate 0.1.8 against purescript-either.git#~0.1.4
bower purescript-monoid#~0.1.4 cached purescript-monoid.git#0.1.5
bower purescript-monoid#~0.1.4 validate 0.1.5 against purescript-monoid.git#~0.1.4
bower purescript-tuples#~0.2.3 cached purescript-tuples.git#0.2.3
bower purescript-tuples#~0.2.3 validate 0.2.3 against purescript-tuples.git#~0.2.3

Unable to find a suitable version for purescript-arrays, please choose one by typing one of the numbers below:
1) purescript-arrays#~0.2.1 which resolved to 0.2.1 and is required by purescript-path#0.2.7
2) purescript-arrays#~0.3.0 which resolved to 0.3.7 and is required by purescript-foldable-traversable#0.1.6, purescript-monoid#0.1.5, purescript-tuples#0.2.3

Prefix the choice with ! to persist it to bower.json


#2

The problem is most likely that purescript-path is not compatible with the rest of your project. Looking at the github repo (which you can find by running bower info purescript-path), the last commit is from 2014. The compiler and core libraries have had quite a few breaking changes since then, which means that you’ll need to fork purescript-path and do a bit of work to update it if you want to use it with a recent version of the compiler.