Problem compiling compiler on FreeBSD

haskell

#1

Having trouble following the instructions for the compiler at Compiling from source.
It comes up with error “Please create a package description file .cabal” for files SHA-1.6.4.4 and alex-3.2.4, which seems to be among the first parts of the build (2/122). This’s on FreeBSD 12.0 using latest versions of stack and ghc.
Thank in advance, Ben.


#2

Latest version of ghc is 8.6.3 in the FreeBSD ports… For me, switching the system ghc to the 8.4.4 package did the trick - but I also ommitted the additional flag and just used stack install


#3

Thanks for that, still haven’t got it working but it’s good to know that it’s possible. Guess I’ll have to learn how to use stack/ghc properly.


#4

It‘s definitely possible. I messed around with stack and cabal before, so I might inadvertently have laid the groundwork, but otherwise the installation instructions worked for me.


#5

FYI: I’ve just managed to build spago with the FreeBSD System ghc 8.6.3:

I used the following ~/.stack/config.yaml

system-ghc: true
compiler-check: newer-minor
allow-newer: true
skip-ghc-check: true

and then changed stack.yaml to use

resolver: lts-13.13


#6

Same method works for purescript 0.12.3 on FreeBSD, if the

-XNoMonadFailDesugaring

Compiler option is added to purescript.cabal


#7

Finally got it to work with those settings. Now I’ll have to go back and work out why its working.

Thankyou very much!