Silent failure of VSCode extension


I’m trying to install the “PureScript Language Support” VSCode plugin on two Windows machines (using the Ubuntu subsystem) and can’t get it to work on either. I’ve had this before on the Mac and never really understand what I do to fix it – eventually it starts working and by that point I’ve lost track of how (and usually the will to live). But this time we seem to be stuck with no visibility on what’s happening.

If I run PureScript:Build nothing happens – is there a way to see what the extension is trying to do? I have

   “purescript.trace.server”: “verbose”

set in settings.json but can’t see any output anywhere. Where should we be looking?

Similarly, if I run “Purescript:Restart/Reconnect purs IDE server” nothing happens with no logging/error messages anywhere.

On my Mac where everything works fine, but I still can’t directly see anything happening – I can only indirectly observe whether the server is running, e.g. by trying to navigate to a definition. Stopping and restarting the server work inasmuch as features stop/start working, but it’s otherwise opaque.

Any clues on how to witness the IDE trying to start/connect to the server or run build commands?