Unable to see output on running spago commands in Purescript

Hi everyone,

Whenever I run spago commands like spago build, spago run, a new window opens up temporarily and vanishes, but I am not able to see the output. Can somebody assist in resolving this?

Do you run these commands from a command-prompt?
Are the commands doing what they should (for example is spago build building your project)?

I tried using both command prompt as well as visual studio code text editor and in both cases it happens. Though I am not sure that whether spago build is building my project or not as terminal windows closes very quickly

This might be related to you other issue - I’d start by upgrading node.js

I analyzed the code and found that spago is building the project and code is also running (I was able to see because for sometime --watch command worked). However, I am unable to see the output now.

I am mentioning the versions below. Let me know the way forward

Node.js - node-v14.16.1-x64.msi
Purescript and spago - npm install -g purescript@0.14.1 spago@0.20.1
npm 6.14.12
node v14.16.1

Is there a reason why you are using older versions of node.js and purescript?